欢迎光临
我们一直在努力

配置Spring的时候,配置文件中最好不要去指定Spring的版本

我们在配置Spring的时候,按照惯例会如此配置:

因为配置项很多,都懒得记所以会保存一个模板,每次新建项目的时候复制粘贴就行了。但是,我比较喜欢当前最新稳定版,所以我就要手动去修改成4.3,感觉很麻烦,万一哪天生产环境要求用Spring3.x的呢?那么最好的办法就是不要去指定版本,不指定版本默认就会链接到当前版本的.xsd,如果要切换版本,只需要在Maven中更改配置版本号即可,不过如果你的项目严重依赖某个版本,那么此时就需要指定版本号了。

 

未经允许不得转载:李阳博客 » 配置Spring的时候,配置文件中最好不要去指定Spring的版本

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址